Nos cenários de mudança para o POS Cloudware, e de forma a facilitar a migração dos fornecedores do software anterior, desenvolvemos uma funcionalidade de importação dos clientes através de um ficheiro .CSV (Excel). Vê como abaixo.


1. Deves começar por exportar o ficheiro com os dados dos fornecedores do teu software anterior


A grande maioria dos softwares permite a exportação dos dados dos fornecedores; caso não encontres a opção no teu software anterior, contacta o suporte ao cliente.


Deves igualmente verificar que o ficheiro está no formato CSV.

Para gravar um ficheiro em formato .CSV, deves seguir os passos abaixo.
1. Abre o ficheiro;
2. Seleciona a opção de menu Ficheiro > Guardar Como;
3. No campo Tipo de Ficheiro, escolhe a opção CSV (.csv);
4. Clica em Guardar.


2. Abre o ficheiro .CSV e organiza as colunas pela ordem abaixo indicada


Nome | NIF | Morada | Código Postal | Localidade | País | Telefone | Telemóvel | E-Mail | Website.

Está disponível um Ficheiro Exemplo na opção de menu Configuração > Migração de Dados > Fornecedores > Download Ficheiro Exemplo.


Organizadas as colunas do ficheiro, grava o ficheiro .CSV.

Deves preencher o nome de todos os fornecedores.
Caso pretendas indicar o País de origem dos fornecedores, deves associar a sigla e não o nome completo do país. Por exemplo, para Portugal deves colocar PT. Consulte a lista completa, clicando aqui.



3. Importar o ficheiro .CSV para o POS Cloudware


Para importar o ficheiro .CSV com os clientes para o POS Cloudware deves aceder à opção de menu Configuração > Migração de Dados > Fornecedores > Importar.



Seleciona o ficheiro .CSV e inicia a importação.


Em poucos segundos, o POS Cloudware processa o ficheiro e encaminha-te para um novo ecrã, onde podes verificar os fornecedores com erro, organizar a informação e adicionar / remover dados por fornecedor.



O botão Alterar Estrutura permite a organização das colunas do ficheiro, no caso destas não estarem na ordenação acima indicada. 


Caso as colunas sejam diferentes (em menor número ou em posições diferentes), podes atribuir o campo à coluna correta.

Esta opção está apenas disponível para a importação de ficheiros .CSV.



Para concluir, basta clicar em Gravar.


Caso tenhas necessidade de alterar individualmente os dados dos fornecedores, podes clicar na linha do fornecedor e editar os campos necessários.


Esta é uma opção bastante útil, sendo que podes utilizar o campo Pesquisar para localizar mais facilmente os fornecedores.

A pesquisa de fornecedores funciona para qualquer campo da ficha do fornecedor, pelo que podes pesquisar pelo nome, NIF, código postal ou localidade.



Para concluir, basta clicar em Gravar.



No quadro Resumo, à direita no ecrã, é indicado o número de registos que integram o ficheiro .CSV, o número de novos registos ou de registos que serão atualizados (caso já tenham sido previamente importados), o número de registos válidos e, caso existam, o número de registos inválidos.


Para consultar os registos inválidos, basta clicar no número de registos inválidos, no quadro Resumo, sendo aplicado um filtro que mostra apenas os registos inválidos na lista. Para corrigir, basta clicar na linha do cliente inválido e preencher / corrigir os campos em falta / errados.



Para concluir a importação, deves clicar em Importar



A partir deste momento, o POS Cloudware dá início à importação dos fornecedores, que poderá ser mais ou menos demorada, considerando a dimensão do ficheiro e o número de fornecedores a importar. 

Caso pretendas continuar o trabalho no POS Cloudware, podes abandonar a página, pois o processo de importação fica a trabalhar em background.


No final do processo de importação, o POS Cloudware apresenta um resumo da operação.




Cláudio Miguel Carneiro

Equipa Cloudware